I'm trying to create an m4 macro that basically calls AC_CHECK_SIZEOF(type) then uses AC_SUBST to define that variable for substitution. So given input of:
AX_CHECK_SIZEOF_AND_SUBST(int, 4)
I want all occurances of @SIZEOF_INT@
to be replaced with 4
This is what I came up with so far, but obviously doesn't work:
AC_DEFUN([AX_CHECK_SIZEOF_AND_SUBST], [
AC_CHECK_SIZEOF($1, $2)
NAME=$(echo -n "SIZEOF_$1" | tr "a-z" "A-Z" | tr '*' 'P' | tr -c 'A-Z0-9' '_')
echo "NAME=$NAME"
AC_SUBST($NAME, $$NAME)
])
The trouble with what you are trying to do is that
AC_CHECK_SIZEOF
does not in fact define a variable namedSIZEOF_INT
. In 2.68, the variable you want is namedac_cv_sizeof_int
, but you should not use that as the name is subject to change in later versions. The value is also written into confdefs.h, so another way to grab it is:(reading confdefs.h is also undocumented behavior and subject to change in future versions of autoconf, but is possibly more stable than looking at $ac_cv_sizeof_int. Possibly, less stable, too. ;) YMMV)
To define your macro (please note my comment about the naming convention), you could do:
The version above does not handle
int *
, but for simplicity I will keep it there rather than replace it with the more general version:Note: I believe the
$()
notation should be avoided in portable configure scripts, and should be replaced with backticks. However, I find backticks hideous.