I currently have a problem figuring out how to use the ImageResizer plugin to properly work with SQL and the DiskCache plugin.
My strategy for naming is as follows:
/myimagetitle-4319560-100x100.jpg
is rewritten to /4319560.jpg?id=4319560&title=myimagetitle&height=100&width=100
by the IIS URL Rewrite module.
This works as expected.
Now, in order to find the file name for the image, I need to translate the id using SQL. I have created a IVirtualImageProvider
plugin, which implements the FileExists
and the GetFile
methods.
public IVirtualFile GetFile(string virtualPath, NameValueCollection queryString)
{
var path = this.GetOriginalFilePath(queryString);
return new VirtualFileWrapper(new ProductPhotoVirtualFile(path));
}
public bool FileExists(string virtualPath, NameValueCollection queryString)
{
if (File.Exists(this.GetCachedFilePath(queryString)))
{
return true;
}
if (File.Exists(this.GetOriginalFilePath(queryString)))
{
return true;
}
return false;
}
private string GetCachedFilePath(NameValueCollection queryString)
{
// Get customized cache file path based on the query string
// "cache\4319\560\4319560_w_100_h_100.jpg"
}
private string GetOriginalFilePath(NameValueCollection queryString)
{
// Perform SQL lookup to translate the id from the query to a file name
}
I am using the DiskCache plugin to ensure my images are cached using IIS etc.
Unfortunately, the FileExists
method is always run, executing the SQL on each request.
What I would like to achieve is the following:
- have the DiskCache plugin run before the
FileExists
method, and in that way skip the actual SQL lookup, if the file is cached - handle the cache file naming strategy, in order for other tools to generate the images in the correct folders.
Is any of the above possible and/or am I doing something wrong?
Thanks
FileExists
will always be called, as there's no other way to determine which IVirtualImageProvider should be responsible for the request — and therefore which is responsible for providing caching details like modified date and keys. A better name for it would beIsHandled
In practice, it's OK to lie within the FileExists method, as throwing a FileNotFoundException during .Open() later will also be handled as a 404. It's not OK to lie within FileExists if it will prevent another IVirtualImageProvider from working.
In your case, you should return true from FileExists if the image URL is in the format you're expecting (I.e, has an ID, or is within the path structure dedicated to SQL image blobs). Typically it's best to use a path prefix, though, as it's hard to predict more complex patterns reliably.