How do I "nice" an already running process?

1.1k Views Asked by At

I have this process, "kernal_task", that is regularly taking 80% of my CPUs. I'd like to "nice" it down to 20, but it's already running.

Is there any way in the Mac OS/X bash to decrease the priority of an already running process?

2

There are 2 best solutions below

0
On
RENICE(8)                 BSD System Manager's Manual                RENICE(8)

NAME
     renice -- alter priority of running processes

SYNOPSIS
     renice priority [[-p] pid ...] [[-g] pgrp ...] [[-u] user ...]
     renice -n increment [[-p] pid ...] [[-g] pgrp ...] [[-u] user ...]
0
On

Yes, you can use renice:

If kernal_task is PID 2243:

renice 20 2243