what is the opposite of this code --> password.getPassword().length == 0
Like instead of empty you check if it is filled.
JButton confirm = new JButton("Sign Up");
confirm.addActionListener(new ActionListener() {
public void actionPerformed(ActionEvent evt) {
UserInfo a = new UserInfo();
/*here is my problem I want it to Check if someone inputted a password so I can
proceed to open the second frame */
if(!firstname.getText().trim().isEmpty() && !lastname.getText().trim().isEmpty() && password.getPassword().length == 0 && pass2.getPassword().length == 0
&& !address.getText().trim().isEmpty() )
a.frame2.setVisible(true);
frame.dispose();
if(firstname.getText().trim().isEmpty()) {
missingfirst.setText("Please Add Your First Name.");
}
if(lastname.getText().trim().isEmpty()) {
missinglast.setText("Please Add Your Last Name.");
}
if(password.getPassword().length == 0) {
missingpass.setText("Please Add A Password.");
}
if(pass2.getPassword().length == 0) {
missingrepass.setText("Please Re-Type Your Password.");
}
if(address.getText().trim().isEmpty()) {
missingadd.setText("Please Enter An Address.");
}
else if (!(password.getPassword().equals(pass2.getPassword()))) {
missingrepass.setText("Password Doesn't Match.");
}
}
}
Check using
password.getPassword().length > 0
or!password.getPassword().isEmpty()
.I think here you should validate if the password entered is in correct format that you require rather than check if it is filled.