Each line is the same number and in all three triangles the number is the same.
Input:
- The first line contains an integer n that represents the number of data sets to follow.
- Each data set will consist of 1 integer m that represents the number that the Triforce of Courage contains throughout.
Output:
Print out a triforce, using this template (replacing 0 with the integer specified):
0 000 00000 0 0 000 000 00000 00000
Assumptions: The number to be replaced will be:0<=m<=9
Sample Input: 1 2
Sample Output:
2 222 22222 2 2 222 222 22222 22222
The following is my code thus far:
import java.lang.Math;
import java.util.Scanner;
import java.io.*;
import java.util.*;
import java.io.FileNotFoundException;
public class TriforceOfCourage {
public static void main(String[] args) throws FileNotFoundException {
Scanner scan=new Scanner(new File("num.dat"));
int n = scan.nextInt();
int count = 0;
while(count<n) {
for (int i=0; i<3; i++) {
for (int k=0; k<3-i; k++) {
System.out.print(" ");
}
for (int j=0; j<i*2+1; j++) {
System.out.print(n);
}
System.out.println("");
}
break;
}
}
}
There are many possible solutions to this problem. In general, there are many good strategies you would typically use to solve this:
Let's take your example. At a glance, personally, I would divide the output into two halves; the top, consisting of a single triangle, and the bottom, consisting of a two triangles side by side. Further, let's focus on just being able to draw a triangle at all. Let's say we want to produce this, a triangle at an arbitrary location:
We notice the triangle is centered on column 7, and we suspect it will help us if we can draw a triangle in any column, so let's let
center
be the center column of our triangle. A lot of these types of strategies involve coming up with a way to parameterize the problem. For this approach we want to find the answer to this question:row
,column
, andcenter
, should we draw a character at that location?Let's take a simple algebraic approach first, one row at a time, and see if we notice any patterns:
row == 0
: Here we output only whencolumn == center
.row == 1
: Here we output whencolumn >= center - 1 && column <= center + 1
.row == 2
: Here we output whencolumn >= center - 2 && column <= center + 2
.Notice a pattern? Think about it for a second. Recognizing that
row == 0
isn't actually a special case, the pattern is:column >= center - row && column <= center + row
.Great! Now we can output a triangle very easily:
But what about two triangles, for the bottom half? The simplest of course would be to do the exact same as above, but since we have two triangles, we have two centers (say,
centerL
andcenterR
), and can simply add a secondif
block in our bottom-half loop -- same logic for both centers, all in one loop. I'll leave this as an exercise to you.Now, like I said, there are many possible solutions. Choose the one that makes the most sense for you and is easiest for you to get your head around. In fact, as a learning exercise, I would suggest trying to implement this program with at least three different algorithms. For example:
if
at all (e.g. loops to output fromcenter - row
tocenter + row
, and separate loops for the borders) - this is similar to your current approach.And of course,