Stateless React components should be named in PascalCase, so React can distinguish between native elements and components. Typescripts naming convention dictates that we should use lowerCamelCase or UPPER_CASE for the name of const variables.
How can I satisfy both (React and tslint)?
I think you have two options here:
Use where appopriate comment like this
/* tslint:disable-next-line:variable-name */
to disable tslint warning at that particular line
Use class components instead of functional ones.